Quaatso Education

Home Forums Selenium Forum Having problem with configuring the selenium beta 3.0

Having problem with configuring the selenium beta 3.0

This topic contains 1 reply, has 2 voices, and was last updated by  Nandan Singh 1 year, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4410

    Jyotish Phukon
    Participant

    Can you plz advise me the link of downloading selenium 3.0? Not sure if I am using the correct one..

    When I set the build path using <span style=”line-height: 1.5;”>selenium 3.0 jars I downloaded still it’s unable to resolve the below code</span>

    “FirefoxDriver driver=new FirefoxDriver();”

     

    and showing FirefoxDriver cannot be resloved to a type.

     

     

    #4411

    Nandan Singh
    Keymaster

    Jyotish, you have to first unzip the jar file you have downloaded and then add following files in your project :

    1. selenium-java-2.53.1

    2. Open “lib” folder and add all jar files inside “lib” folder.

    3. Once you done, you will be import the files, you have to follow given steps to configure with “3.0” beta:

    Please try following steps for using this :

    1. Download Marionette Driver from following link  :

    https://github.com/mozilla/geckodriver/releases

    2. Save above file at some location and unzip same.

    3. Now copy the path till the marionette executable file and use following code :

    File path = new File(“E:\\driver\\geckodriver.exe”); // this is the path till executable file

    System.setProperty(“webdriver.gecko.driver”, path.getAbsolutePath());

    WebDriver driver = new FirefoxDriver();

    driver.get(“https://www.facebook.com/”);

     

     

    Hope this will solve your problem.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.